HDU-Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 196921    Accepted Submission(s): 49358


Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
 
  
1 1 3
1 2 10
0 0 0
 

Sample Output

 
  
2
5            

一个类似斐波那契额数列的东西,但是n的数据太大

所以可以通过找规律来做,一直两个数相加而且mod7,所以一共有0-48个49的数,所以可以对n % 49 来做

#include<iostream>  
using namespace std;  
int slove(int a, int b,int n)  
{  
    if(n==1 || n==2)  
        return 1;  
    else  
        return (a*slove(a,b,n-1)+b*slove(a,b,n-2))%7;  
}  
int main()  
{  
    int a,b,n;  
    while(cin>>a>>b>>n,a||b||n)  
    {  
        cout<<slove(a,b,n%49)<<endl;  
    }  
    return 0;  
}  

如果这种不确定的话,还有一种方法自己找规律

#include<iostream>
using namespace std;
#define ll long long
const int maxn=20000;
int f[maxn];
int main()
{
    int a, b, n;
    f[1] = f[2] = 1;
    while(scanf("%d %d %d", &a, &b, &n), a || b || n){
        int i;
        for (i = 3; i < 20000; i++) {
            f[i] = (a * f[i-1] + b * f[i-2]) % 7 ;
            if (f[i] == 1 && f[i-1] == 1)
                break;
        }
        n %= (i-2) ;
        f[0] = f[i-2] ;
        printf("%d\n", f[n]);
    }
    return 0;
}

这个有一个bug 不能把循环中的20000换成n不然会超时。。。。。。

不知道为什么

猜你喜欢

转载自blog.csdn.net/henu_jizhideqingwa/article/details/80543948