Number Sequence HDU - 1711

 Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], … , a[N]. The third line contains M integers which indicate b[1], b[2], … , b[M]. All integers are in the range of [-1000000, 1000000].
Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

使用strstr()函数会超时(O(m*n)), KMP(O(m+n))

#include <iostream>
#include <vector>
#include <algorithm>
#include <set>
#include <string.h>
#include <stdio.h>
using namespace std;
#define N 1000005
int s[N];
int p[N];
int next[N];
int m,n;
void getnext()
{
    
    
    int j=0,k=-1;
    next[0]=-1;
    while(j<m)
    {
    
    
        if(k==-1||p[j]==p[k])
        {
    
    
            j++;
            k++;
            next[j]=k;
        }
        else
            k=next[k];
    }
}
int kmp()
{
    
    
    int i=0,j=0;
    getnext();
    while(i<n)
    {
    
    
        if(j==-1||s[i]==p[j])
        {
    
    
            i++;
            j++;
        }
        else
            j=next[j];
        if(j==m)
            return i;
    }
    return -1;
}
int main()
{
    
    
    int t;
    scanf("%d",&t);
    while(t--)
    {
    
    
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
            scanf("%d",&s[i]);
        for(int i=0; i<m; i++)
            scanf("%d",&p[i]);
        if(kmp()==-1)
            printf("-1\n");
        else
            printf("%d\n",kmp()-m+1);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/JdiLfc/article/details/108986044