HDU-1711 Number Sequence

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

Sample Output

6
-1

代码:

#include <stdio.h>
#include <string.h>
int n,m;
int next[1000010];
int a[1000010],b[1000010];

void getnext(int p[])
{
	next[0]=-1;
	int k=-1;
	int j=0;
	while(j<m-1)
	{
		if(k==-1||p[j]==p[k])
		{
			j++;
			k++;
			if(p[j]!=p[k])
				next[j]=k;
			else
				next[j]=next[k];
		}
		else
			k=next[k];	
	}
}

int kmp(int a[],int b[])
{
	int i=0;
	int j=0;
	while(i<n&&j<m)
	{
		if(j==-1||a[i]==b[j])
		{
			i++;
			j++; 
		}
		else
			j=next[j];
	} 
	if(j==m)
		return i-j+1;
	else
		return -1;
}

int main()
{
	int t,i;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<m;i++)
			scanf("%d",&b[i]);
		getnext(b);
		if(n<m) 
			printf("-1\n");
        else 
			printf("%d\n",kmp(a,b));
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/hello_cmy/article/details/81193110