hdu1711 : Number Sequence

http://acm.hdu.edu.cn/showproblem.php?pid=1711

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

Sample Input

2

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 1 3

13 5

1 2 1 2 3 1 2 3 1 3 2 1 2

1 2 3 2 1

Sample Output

6

-1

题目意思是给出a串和b串,找出b串在a串中最早出现的位置,如果没有,输出-1。kmp算法求解。

#include<stdio.h>
#include<string.h>
#define N 1000020
int m,n,flag;
int a[N],b[N],next[N];
void get_next(int m)
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<m)
    {
        if(j==-1||b[i]==b[j])
        {
            i++;
	    j++;
            next[i]=j;
        }
        else
        j=next[j];
    }
}
int kmp(int n,int m)
{
    int i=0,j=0;
    get_next(m);
    while(i<n)
    {
        if(j==-1||a[i]==b[j])
        {
            i++;
			j++;
        }
        else
        j=next[j];
        if(j==m)
        {
            flag=1;
            return i-j+1;
        }
    }
    return 0;
}
int main()
{
	int k,i,j,ans;
	scanf("%d",&k);
	while(k--)
	{
		memset(next,0,sizeof(next));
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		scanf("%d%d",&n,&m);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		for(i=0;i<m;i++)
			scanf("%d",&b[i]);	
		if(n<m)
			printf("-1\n");
		else
		{
			flag=0;
			ans=kmp(n,m);
			if(flag==0)
				printf("-1\n");
			else
				printf("%d\n",ans);
		}
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/qq_41505957/article/details/81707066