HDU - 1576 - A/B 【数论+欧几里得】题解

1.题目

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
Output
对应每组数据输出(A/B)%9973。
Sample Input
2
1000 53
87 123456789
Sample Output
7922
6060

2.代码

#include<iostream>
#include<cstdio>
const int mod=9973;
using namespace std;
int exGcd(int a,int b,int &x,int &y)
{
	if(b==0)
	{
	 	 x=1;
	 	 y=0;
	 	 return a;
	}
	int g=exGcd(b,a%b,x,y);
	int temp=x;
	x=y;
	y=temp-a/b*y;
	return g;
}
int main()
{
  int t,n,b;
  cin>>t;
  while(t--)
  {
 	 cin>>n>>b;
 	 int x=0,y=0;
 	 int b1=exGcd(b,mod,x,y);
 	 if(x<0) x+=mod;
 	 int ans=(n*(x%mod)+mod)%mod;
 	 cout<<ans<<endl;
  }
  return 0;	
} 

猜你喜欢

转载自blog.csdn.net/weixin_45629285/article/details/106722121