HDU-1003 Max Sum(dp)

Problem Description:

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

Input:

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output:

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input:

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output:

Case 1:
14 1 4

Case 2:
7 1 6

思路:

开一个dp数组,其元素是把当前遍历到的原数组的元素加入到子段后子段和的最大值,一边遍历一边寻找dp数组的最大值,并及时标记起始下标和终止下标。

上AC代码:

#include <stdio.h>
int pre,hou;
int dp[100001];
int num[100001];
int k;
int t,j;
int main()
{
    scanf("%d",&t);
    for(j=1;j<=t;j++)
    {
        if(j>1)
            printf("\n");
        int i;
        scanf("%d",&k);
        for(i=0;i<k;i++)
        {
            scanf("%d",&num[i]);
        }
        int temp_pre=0;
        pre=0;
        hou=0;
        dp[0]=num[0];
        int Max=dp[0];
        for(i=1;i<k;i++)
        {
            if(dp[i-1]+num[i]<num[i])
            {
                temp_pre=i;
                dp[i]=num[i];
            }
            else
            {
                dp[i]=dp[i-1]+num[i];
            }
            if(dp[i]>Max)
            {
                pre=temp_pre;
                Max=dp[i];
                hou=i;
            }
        }
        printf("Case %d:\n",j);
        printf("%d %d %d\n",Max,pre+1,hou+1);
    }
    return 0;
}
发布了72 篇原创文章 · 获赞 203 · 访问量 9万+

猜你喜欢

转载自blog.csdn.net/weixin_41676881/article/details/89217491
今日推荐