HDU-Max Sum(dp)

                                                  Max Sum

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2

5 6 -1 5 4 -7

7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:

14 1 4

Case 2:

7 1 6

题意描述:

输入一个T表示T组样例,然后输入n表示有n个数,求连续的最大数的和,可以先定义一个sum,表示连续数字的和,如果sum小于0了,则把sum初始化为0,然后再定义一个max,存储最大sum,也就是最大连续数字的和。

程序代码:

#include<stdio.h>
int a[100010];

int main()
{
	int T,i,k,n,sum,max,p,q,t;
	scanf("%d",&T);
	for(k=1;k<=T;k++)
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);	
		sum=0;
		max=-99999999;
		t=p=q=1;
		for(i=1;i<=n;i++)
		{
			sum+=a[i];
			if(sum>max)
			{
				max=sum;
				p=t;
				q=i;
			}
			if(sum<0)
			{
				sum=0;
				t=i+1;
			}
		}
		printf("Case %d:\n%d %d %d\n",k,max,p,q);
		if(k!=T)
			printf("\n");
	}	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/82896673