HDU - 1024 Max Sum Plus Plus DP

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ iy ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S2, S 3 ... S n
Process to the end of file. 

Output

Output the maximal summation described above in one line. 

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8


        
  

Hint

Huge input, scanf and dynamic programming is recommended.

题意:给n个数,让你分成m个互不相交的段,m个段的总和最大;

思路:很容易想到   dp[i][j]表示前i个数分成j个段的最大值 dp[i][j]=max(dp[i-1][j]+a[i],dp[k-1][j-1]+a[i])j<=k<i

dp[k-1][j-1]可以用一个数组pre数组存,pre[j]表示前i-1个数分成j段的最大值  dp[i][j]=max(dp[i-1][j]+a[i],pre[j-1]+a[i])

用滚动数组优化就行了, 然后疯狂超时;百度了一下,看了一下kb的写法

dp[i][j]表示前j个数分成i段的最大值,dp[i][j]=max(dp[i][j-1]+a[j],dp[i-1][k]+a[j]) i-1<=k<=j-1

dp[i-1][k]可以用一个数组maxx求出来,(k<j)maxx[k]表示第i段前k个数的最大值  k>=j表示第i-1段前k个数的最大值 

dp[i][j]=max(dp[i][j-1]+a[j],maxx[j-1]+a[j])  然后改变  maxx[j-1]的值  从表示i-1段到表示i段(第i段用不上了,所以可以改变)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#include<vector>
#include<set>
#include<queue>
#include<algorithm>
#include<stack>
#include<cstdlib>
#include<deque> 
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<double,double>P;
const int INF=0x3f3f3f3f;
const int len=1e6+5;
const double pi=acos(-1.0);
const ll mod=1e8+7;
int dp[len],maxx[len],a[len]; 
int main()
{
	int n,m;
	while(~scanf("%d%d",&m,&n))
	{
		for(int i=1;i<=n;++i)
		{
			scanf("%d",&a[i]);
			dp[i]=0;
			maxx[i]=0;
		}
		dp[0]=0;
		maxx[0]=0;
		int ans;
		for(int i=1;i<=m;++i)
		{
			ans=-INF;
			for(int j=i;j<=n;++j)
			{
				dp[j]=max(dp[j-1]+a[j],maxx[j-1]+a[j]);
				maxx[j-1]=ans;
				ans=max(ans,dp[j]);
				
			}
		}
		printf("%d\n",ans);
	}
}

猜你喜欢

转载自blog.csdn.net/hutwuguangrong/article/details/88618274