hdu 基础DP 1002 Max Sum

Max Sum

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 99   Accepted Submission(s) : 36

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

Author

Ignatius.L

#include <bits/stdc++.h>
using namespace std;
int a[100005];
int main()
{
    int m,cnt=1;
    scanf("%d",&m);
    while(m--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&a[i]);
        int cur=a[1],pre=a[1];
        int lss=1,s=1,e=1;
        for(int i=2;i<=n;i++)
        {
            if(pre<0)//前面之和为负数,临时起点从此时开始
            {
                lss=i;
                pre=a[i];
            }
            else//和>=0,直接加
            {
                pre+=a[i];
            }
            if(pre>cur)
            {
                cur=pre;
                s=lss;
                e=i;
            }
        }
        printf("Case %d:\n",cnt++);
        printf("%d %d %d\n",cur,s,e);
        if(m!=0) printf("\n");   //格式问题PE了好多次,每两组样例之间空一行
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/80974818