Max Sum Plus Plus HDU - 1024 dp

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ iy ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S2, S 3 ... S n. 

Process to the end of file. 

Output

Output the maximal summation described above in one line. 

Sample Input

1 3 1 2 3 2 6 -1 4 -2 3 -2 3

Sample Output

6 8

Hint

Huge input, scanf and dynamic programming is recommended.

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define N 1000000
int a[N+10],dp[N+10],maxn[N+10];
int main()
{
	int m,n;
	while(~scanf("%d %d",&m,&n))
	{
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&a[i]);
		}
		memset(dp,0,sizeof(dp));
		memset(maxn,0,sizeof(maxn));
		int ma;
		for(int i=1;i<=m;i++)
		{
			 ma=-1000000000;
			for(int j=i;j<=n;j++)
			{
				dp[j]=max(dp[j-1]+a[j],maxn[j-1]+a[j]);
				maxn[j-1]=ma;
				ma=max(ma,dp[j]);
			}
		}
		printf("%d\n",ma);
	}
	
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/liuliu2333/article/details/81086673