Max Sum Plus Plus HDU - 1024 (dp)

A - Max Sum Plus Plus HDU - 1024

Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 … S x, … S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + … + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + … + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. _

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 … S n.
Process to the end of file.

Output

Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

Hint

Huge input, scanf and dynamic programming is recommended.



题意:

在n个数中选出m组数, 每组数连续且不能相交, 求出最大的各组数的和

题解:

  • 首先定义dp[i][j]为状态: 在前j个数中恰好选出i组数的最大和
  • 得出状态转移方程 d p [ j ] [ j ] = m a x ( d p [ i ] [ j 1 ] , d p [ i ] [ j 1 ] + a [ j ] , d p [ i 1 ] [ k ] + a [ j ] ( 0 < k < j ) ) dp[j][j] = max(dp[i][j-1], dp[i][j-1]+a[j], dp[i-1][k]+a[j](0<k<j) )
    意义依次为不取第j个数, 取第j个数归入当前组, 取第j个数归入新的组.
  • 显然 n 2 n^2 的复杂度, 不管是空间还是时间都无法通过, 我们考虑优化, 首先dp[i][j-1]和 dp[i-1][k]+aj其实和dp[i-1][k]+aj含义是相似的, 试想不取当前这个数, 其实就是在之后的某个地方开了新的组把这个数弹出来了.
    而且和背包问题一样, 只和dp[i-1]这一层有关, 我们用一维数组来滚动就可以啦, 顺序不变
  • 最后dp[i-1][k]其实就是上一组j之前最大的dp, 我们用一个数组来存一下就好了
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
#define ms(x, n) memset(x,n,sizeof(x));
typedef  long long LL;
const LL maxn = 1e6+10;
const int inf = 1<<30;

int m, n, a[maxn], dp[maxn];
int lastMax[maxn]; //i-1时前j个数的最大dp
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF){
        for(int i = 1; i <= n; i++)
            scanf("%d",&a[i]);

        ms(dp, 0); dp[0]=-inf;
        ms(lastMax, 0)
        int mmax;
        for(int i = 1; i <= m; i++){
            mmax = -inf;
            for(int j = i; j <= n; j++){
                dp[j] = max(dp[j-1]+a[j], lastMax[j-1]+a[j]);
                lastMax[j-1] = mmax;
                mmax = max(mmax, dp[j]);
            }
        }

        printf("%d\n",mmax);
    }

	return 0;
}

猜你喜欢

转载自blog.csdn.net/a1097304791/article/details/87872686