Triangle Partition HDU - 6300

 2018 Multi-University Training Contest 1

Triangle Partition HDU - 6300 

Chiaki has 3n3n points p1,p2,…,p3np1,p2,…,p3n. It is guaranteed that no three points are collinear. 
Chiaki would like to construct nn disjoint triangles where each vertex comes from the3n3n points. 

Input

There are multiple test cases. The first line of input contains an integer TT, indicating the number of test cases. For each test case: 
The first line contains an integer nn (1≤n≤10001≤n≤1000) -- the number of triangle to construct. 
Each of the next 3n3n lines contains two integers xixi and yiyi (−109≤xi,yi≤109−109≤xi,yi≤109). 
It is guaranteed that the sum of all nn does not exceed 1000010000. 

Output

For each test case, output nn lines contain three integers ai,bi,ciai,bi,ci (1≤ai,bi,ci≤3n1≤ai,bi,ci≤3n) each denoting the indices of points the ii-th triangle use. If there are multiple solutions, you can output any of them. 

Sample Input

1
1
1 2
2 3
3 5

Sample Output

1 2 3


#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int T;
int n,a[3005],x[3005],y[3005];
bool pan(int p,int q)
{
    return x[p]>x[q];
}
int main()
{
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=1;i<=3*n;i++)
        {
            a[i]=i;
            scanf("%d%d",&x[i],&y[i]);
        }
        sort(a+1,a+3*n+1,pan);
        for(int i=0;i<n;i++)
        {
            printf("%d %d %d\n",a[3*i+1],a[3*i+2],a[3*i+3]);
        }
    }
    return 0;
}
发布了19 篇原创文章 · 获赞 3 · 访问量 1394

猜你喜欢

转载自blog.csdn.net/xuanhuangwendao/article/details/81214450