HDU6300 Triangle Partition(2018HDU多校联赛第一场,贪心)

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three
points are collinear. Chiaki would like to construct n disjoint
triangles where each vertex comes from the 3n points.

Input

There are multiple test cases. The first line of input contains an
integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) – the number of
triangle to construct. Each of the next 3n lines contains two integers
xi and yi (−109≤xi,yi≤109). It is guaranteed that the sum of all n
does not exceed 10000.

Output

For each test case, output n lines contain three integers ai,bi,ci
(1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle
use. If there are multiple solutions, you can output any of them.

Sample Input

1
1
1 2
2 3
3 5

Sample Output

1 2 3

思路

给了 3 n 个点,问是否可以组成 n 个三角形,如果可以组成,那么输出组成的这些点的编号。题目保证三个点不共线。

因为题目保证三个点不共线,所以我们可以从左到右贪心,显然,一定可以选择够满足条件的点。所以做法就是对点按照x坐标排序然后输出

代码

#include <cstdio>
#include <cstring>
#include <cctype>
#include <stdlib.h>
#include <string>
#include <map>
#include <iostream>
#include <sstream>
#include <set>
#include <stack>
#include <cmath>
#include <queue>
#include <vector>
#include <algorithm>
#include <list>
using namespace std;
#define mem(a, b) memset(a, b, sizeof(a))
typedef long long ll;
const int N = 5e5 + 10;
const int inf = 0x3f3f3f3f;
struct node
{
    int x, y, id;
} e[N];
bool cmp(node x, node y)
{
    return x.x < y.x;
}
int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        int n;
        scanf("%d", &n);
        for (int i = 1; i <= 3 * n; i++)
        {
            scanf("%d%d", &e[i].x, &e[i].y);
            e[i].id = i;
        }
        sort(e + 1, e + 3 * n + 1, cmp);
        for (int i = 1; i <= 3 * n; i += 3)
            printf("%d %d %d\n", e[i].id, e[i + 1].id, e[i + 2].id);
        puts("");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/riba2534/article/details/81177366