hdu6300

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 137    Accepted Submission(s): 76
Special Judge

 

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

 

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

 

Sample Input

 

1

1

1 2

2 3

3 5

 

Sample Output

 

1 2 3

解析:因为题目说明不可能三点共线。所以我们可以按照x(或y)排个序,每次取最前的3点,可以组成三角形。

#include<bits/stdc++.h>
using namespace std;

#define e exp(1)
#define pi acos(-1)
#define mod 1000000007
#define inf 0x3f3f3f3f
#define ull unsigned long long
#define ll long long

struct node{
    int x,y,id;
}a[3005];
int cmp(node a,node b)
{
    return a.x<b.x;
}
int main()
{
    int t;scanf("%d",&t);
    while(t--)
    {
        int n;scanf("%d",&n);
        for(int i=0; i<3*n; i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);
            a[i].id=i;
        }
        sort(a,a+3*n,cmp);
        for(int i=0; i<3*n; i+=3)
        {
            printf("%d %d %d\n",a[i].id+1,a[i+1].id+1,a[i+2].id+1);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/yu121380/article/details/81174279