HDU-6300 Triangle Partition(贪心)

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

Sample Input

1 1 1 2 2 3 3 5

Sample Output

1 2 3

题意:

扫描二维码关注公众号,回复: 2530918 查看本文章

一共有3n个 点,保证没有三点在同一条直线上,3个点构成一个三角形,保证所有三角形不相交

输出构成每个三角形的三点标号

思路:贪心排序

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N = 1005;
struct node{
	int x,y;
	int id;
	bool operator <(const node p){
		if(x==p.x) return y<p.y;
		return x<p.x;
	}
}arr[N*3];
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		int n;
		scanf("%d",&n);
		for(int i=0;i<n*3;i++){
			scanf("%d%d",&arr[i].x,&arr[i].y);
			arr[i].id=i+1;
		}
		sort(arr,arr+n*3);
		for(int i=0;i<n*3;i+=3){
			printf("%d %d %d\n",arr[i].id,arr[i+1].id,arr[i+2].id);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/islittlehappy/article/details/81183648