HDU 6300:Triangle Partition

Chiaki has 3n3n points p1,p2,…,p3np1,p2,…,p3n. It is guaranteed that no three points are collinear. 
Chiaki would like to construct nn disjoint triangles where each vertex comes from the 3n3n points. 

Input

There are multiple test cases. The first line of input contains an integer TT, indicating the number of test cases. For each test case: 
The first line contains an integer nn (1≤n≤10001≤n≤1000) -- the number of triangle to construct. 
Each of the next 3n3n lines contains two integers xixi and yiyi (−109≤xi,yi≤109−109≤xi,yi≤109). 
It is guaranteed that the sum of all nn does not exceed 1000010000. 

Output

For each test case, output nn lines contain three integers ai,bi,ciai,bi,ci (1≤ai,bi,ci≤3n1≤ai,bi,ci≤3n) each denoting the indices of points the ii-th triangle use. If there are multiple solutions, you can output any of them. 

Sample Input

1
1
1 2
2 3
3 5

Sample Output

1 2 3

给你几个坐标点,看如何才能让他们构成的三角形不重合。直接关于x轴排序

#include<iostream>
#include<cstdio>
#include<algorithm>
#define ll long long
#define maxn 10000000+5
using namespace std;
struct node
{
	ll x;
	ll y;
	ll n;
}ac[maxn];
int cmp(node a,node b)
{
	return a.x<b.x;
}
int main()
{
	ll n;
	scanf("%lld",&n);
	while(n--)
	{
		ll m;
		scanf("%lld",&m);
		for(ll i=1;i<=3*m;i++)
		{
			scanf("%lld%lld",&ac[i].x,&ac[i].y);
			ac[i].n=i;
		}
		sort(ac+1,ac+(m*3+1),cmp);
		for(ll i=1;i<=3*m;i++)
		{
			printf("%lld",ac[i].n);
			if(i%3!=0)
			printf(" ");
			else
			printf("\n");
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41453511/article/details/81384745