Triangle Partition水题

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 891    Accepted Submission(s): 463
Special Judge

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

Sample Input

1

1

1 2

2 3

3 5

Sample Output

1 2 3

Source

2018 Multi-University Training Contest 1

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6308 6307 6306 6305 6304 

这道题主要是想明白由于给的所有点都不共线,就说明一条线上最多有两个点。所以将其以 x 从小到大进行排序 ,然后直接输出就可以了。

代码:

#include<bits/stdc++.h>
using namespace std;
struct node
{
    long long x,y;
    int id;
}lala[10010];
int cmp(node a,node b)
{
    return a.x<b.x;
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=3*n;i++)
        {
            scanf("%lld%lld",&lala[i].x,&lala[i].y);
            lala[i].id=i;
        }
        sort(lala+1,lala+1+3*n,cmp);
        for(int i=1;i<=3*n;i++)
        {
            if(i%3==1||i%3==2)
                cout<<lala[i].id<<" ";
           
            else if(i%3==0)
                cout<<lala[i].id<<endl;
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/xianpingping/article/details/81188077