HDUOJ6300Triangle Partition

HDUOJ6300Triangle Partition

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) – the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

Sample Input

1
1
1 2
2 3
3 5

Sample Output

1 2 3

题意

给3n个保证不存在三点共线的点,组成n个不相交的三角形
对组成的每个三角形,输出组成此三角形的三个点的编号

思路

因为不存在三个共线的点 ,所以任意三个点都能组成一个三角形
就按照每个点的横坐标把点排个序,然后按照从左到右的每三个点组成一个三角形,就酱~

AC代码

#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
    int x, y;
    int no;
}p[3010];
bool cmp(node a, node b)
{
    return a.x < b.x;
}
int main()
{
    int t;
    cin >> t;
    while (t--)
    {
        int n;
        cin >> n;
        for (int i = 1; i <= 3 * n; i ++)
        {
            cin >> p[i].x >> p[i].y;
            p[i].no = i;

        }
        sort(p + 1, p + 1 + 3 * n, cmp);
        for (int i = 1; i <= 3 * n; i ++)
        {
            cout << p[i].no;
            if(i % 3 == 0)
            {
                cout << endl;
            }
            else 
            {
                cout << ' ';
            }

        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wuswi0412/article/details/81274129