HDU- 6300 Triangle Partition(思维)

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 207    Accepted Submission(s): 115
Special Judge

 

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

 

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

 

Sample Input

 

1

1

1 2

2 3

3 5

 

Sample Output

 

1 2 3

 

Source

2018 Multi-University Training Contest 1

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6308 6307 6306 6305 6304 

 

#include<bits/stdc++.h>
using namespace std;
#define LL long long

const int MAXN = 1e5+10;
const int INF = 0x3f3f3f3f;
const int MOD = 1e9+7;
const int N = 1010;

struct node{
    int x,y,id;
}p[MAXN];
int n,t;
bool cmp(node a,node b){
    if(a.x == b.x)
        return a.y < b.y;
    return a.x < b.x;
}
int main(){
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=1;i<=3*n;i++){
            scanf("%d%d",&p[i].x,&p[i].y);
            p[i].id = i;
        }
        sort(p+1,p+1+3*n,cmp);
        for(int i = 1; i <= n*3; i+=3) {
            printf("%d %d %d\n",p[i].id,p[i+1].id,p[i+2].id);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/l18339702017/article/details/81175045