HDU 6300(排序)

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 356    Accepted Submission(s): 189
Special Judge

 

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

 

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

 

Sample Input

 

1 1 1 2 2 3 3 5

 

Sample Output

 

1 2 3

 

Source

2018 Multi-University Training Contest 1

排序。

对所有点极角排序,三个点三个点的取即可

#include <bits/stdc++.h>
#define fir first
#define se second
#define pb push_back
#define ll long long
#define mp make_pair
using namespace std;
const int maxn=1e5+10;
const int maxm=1e6+10;
const int inf=0x3f3f3f3f;
const ll mod=1e9+7;
const double eps=1e-7;
int n;
struct Point{
    double x,y,angle;
    int id;
}p[maxn];
int cmp(Point a,Point b){
    return a.angle<b.angle;
}
int main(){
    int t;
    scanf("%d",&t);
    while (t--){
        scanf("%d",&n);
        for (int i=1;i<=3*n;i++){
            scanf("%lf %lf",&p[i].x,&p[i].y);
            p[i].id=i;
            p[i].angle=atan2(p[i].y,p[i].x);
        }
        sort(p+1,p+3*n+1,cmp);
        for (int i=1;i<=3*n;i+=3){
            printf("%d %d %d\n",p[i].id,p[i+1].id,p[i+2].id);
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wyj_alone_smile/article/details/81177050