Triangle Partition hdu

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

Sample Input

1 1 1 2 2 3 3 5

Sample Output

1 2 3

题目:给出n个点,求出能构成的三角形点的编号,且不存在三角形相交
思路:按照点的x坐标排序,因为不存在三点共线。
代码:
#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=3005;
struct node
{
    int x,y,id;
};
node dian[maxn];
bool cmp(node a,node b)
{
    return a.x<b.x;
}
int main()
{
   int t,n,i,sum[maxn];
   scanf("%d",&t);
   while(t--)
   {
       scanf("%d",&n);
       for(i=1;i<=3*n;i++)
       {
           scanf("%d%d",&dian[i].x,&dian[i].y);
           dian[i].id=i;
       }
       sort(dian+1,dian+1+3*n,cmp);
       for(i=1;i<=3*n;i++)
       {
           sum[i]=dian[i].id;
       }
       for(i=1;i<3*n;i++)
        printf("%d ",sum[i]);
       printf("%d\n",sum[3*n]);
   }
}

猜你喜欢

转载自blog.csdn.net/qq_37748451/article/details/81186158