hdu6300Triangle Partition 贪心

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/xxxslinyue/article/details/81479700

Triangle Partition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 1808    Accepted Submission(s): 914
Special Judge

 

Problem Description

Chiaki has 3n points p1,p2,…,p3n. It is guaranteed that no three points are collinear.
Chiaki would like to construct n disjoint triangles where each vertex comes from the 3n points.

 

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:
The first line contains an integer n (1≤n≤1000) -- the number of triangle to construct.
Each of the next 3n lines contains two integers xi and yi (−109≤xi,yi≤109).
It is guaranteed that the sum of all n does not exceed 10000.

 

Output

For each test case, output n lines contain three integers ai,bi,ci (1≤ai,bi,ci≤3n) each denoting the indices of points the i-th triangle use. If there are multiple solutions, you can output any of them.

 

Sample Input

 

1 1 1 2 2 3 3 5

 

Sample Output

 

1 2 3

 

Source

2018 Multi-University Training Contest 1

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6361 6360 6359 6358 6357 

 

解题思路 : 画个图 猜一猜 从左到右依次三个连在一起就可以了  排个序然后输出即可

#include<bits/stdc++.h>
using namespace std;
struct node{
	int x;
	int y;
	int id;
	bool operator < (const node &a) const{
		return x < a.x;
	}
}a[50005];
int main(){
	
	int t;
	cin>>t;
	while(t--){
		int n;
		cin>>n;
		for(int i=0;i<3*n;i++) { scanf("%d%d",&a[i].x,&a[i].y); a[i].id=i+1;}
		sort(a,a+3*n);
		for(int i=0;i<3*n;i+=3){
			cout<<a[i].id<<" "<<a[i+1].id<<" "<<a[i+2].id<<endl;
		}
	}
	
}

猜你喜欢

转载自blog.csdn.net/xxxslinyue/article/details/81479700