HDU-1213-How Many Tables(并查集/(板子))

How Many Tables

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4
大意:
所有的朋友都不想和陌生人呆在一起。这个问题的一个重要规则是,如果我告诉你A知道B,B知道C,这意味着A,B,C相互了解,所以他们可以呆在一张桌子上。
例如:如果我告诉你A知道B,B知道C,D知道E,那么A,B,C可以放在一张桌子上,D,E必须放在另一张桌子上。所以伊格纳修斯至少需要两张桌子。
代码实现:

//(板子)
#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
int root[1005];
void init()             //赋初值
{
    for(int i=0;i<1005;i++)
    {
        root[i]=i;
    }
}
int findroot(int x)     //找父结点
{
    return root[x]==x?x:x=findroot(root[x]);
}
void Union(int a,int b) //并
{
    int root1=findroot(a);
    int root2=findroot(b);
    root[root1]=root2;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,m,a,b;
        cin>>n>>m;
        init();
        for(int i=0;i<m;i++)
        {
            cin>>a>>b;
            Union(a,b);
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            if(root[i]==i)
            {
                ans++;
            }
        }
        cout<<ans<<endl;
       // printf("\n");
    }
    return 0;
}

(板子)经典的并查集


原题链接:
http://acm.hdu.edu.cn/showproblem.php?pid=1213

发布了33 篇原创文章 · 获赞 35 · 访问量 1272

猜你喜欢

转载自blog.csdn.net/qq_45856289/article/details/103916073
今日推荐