How Many Tables HDU - 1213 (并查集)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49412 Accepted Submission(s): 24568

Problem Description
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4

我的代码:

#include <cstring>
#include <ctime>
#include <iostream>
#include <iomanip>
#include <cmath>
#include <algorithm>
#include <stdlib.h>
using namespace std;
#define maxn 1500

int find_root(int x,int parent[])
{
	int x_root =x;
	while (parent [x_root]!=-1)
	{
		x_root =parent[x_root];
	}
	return x_root;
}
void union_maxn(int x,int y,int parent[],int rank[])
{
	int x_root =find_root(x,parent);
	int y_root =find_root(y,parent);
	if(x_root ==y_root);
	else if(rank[x_root]>rank[y_root])
		parent[y_root]=x_root;
	else if(rank[x_root]<rank[y_root])
		parent[x_root]=y_root;
	else 
	{
		parent[x_root]=y_root;
		rank[y_root]++;
	}
}
int main()
{
	int t;
	cin>>t;
	while(t--)
	{
		int n,m,e=0;
		cin>>n>>m;
		int parent [maxn];
		int rank[maxn];
		int edges[maxn][2];
		memset(parent,-1,sizeof(parent));
		memset(rank,0,sizeof(rank));
		for(int i=1;i<=m;i++)
		{
		    cin>>edges[i][0]>>edges[i][1];
		}
		for(int i=1;i<=m;i++)
		{
			int x=edges[i][0];
			int y=edges[i][1];
			union_maxn(x,y,parent,rank);
		}
		for(int i=1;i<=n;i++)
		if(parent[i]==-1)
		e++;
		cout<<e<<endl;
	}
}

猜你喜欢

转载自blog.csdn.net/weixin_44012551/article/details/86674381