HDU 1213 How Many Tables--简单并查集

How Many Tables
http://acm.hdu.edu.cn/showproblem.php?pid=1213

Problem Description
Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input
2 5 3 1 2 2 3 4 5 5 1 2 5

Sample Output
2 4
题意:
今天是Ignatius的生日,他邀请了许多朋友。现在是吃晚饭的时间,Ignatius想知道他至少需要准备多少桌。必须注意的是,并非所有的朋友都相互认识对方,有的人不愿意和陌生人坐在一桌。针对此问题的一个重要的规则是,如果我告诉你A知道B,B知道C,这意味着,A和C认识对方,这样他们就可以留在一个桌子。但是如果我告诉你,A知道B,B知道C,D知道E,那么ABC可以坐在一起,DE就得另外再坐一桌了。你的任务是请根据输入的朋友之间的关系,帮助Ignatius 求出需要安排多少桌。

思路:直接套用并查集模板就行

#include <iostream>    
using namespace std;  
  
int parent[1002];  
  
void init(int n)//初始化  
{  
    for(int i=1;i<=n;i++)  
        parent[i]=i;  
}  
int find(int x)//寻找根节点  
{  
    return parent[x]==x?x:find(parent[x]);  
}  
  
void unite(int x,int y)//连接,分集合  
{  
    x=find(x);  
    y=find(y);  
    if(x==y)  
        return ;  
    else  
        parent[x]=y;  
}  
int main()
{
	int n,m,t;
	scanf("%d",&t);
	while(t--)
	{
	    scanf("%d%d",&n,&m);
		init(n);
		int x,y;
		for(int i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			unite(x,y);
		}
		int c=0;
		for(int i=1;i<=n;i++)
		{
			if(parent[i]==i)
				c++;
		}
		cout<<c<<endl;
	}
	
}

猜你喜欢

转载自blog.csdn.net/weixin_43965640/article/details/87519379