C - How Many Tables HDU - 1213 (并查集)

C - How Many Tables HDU - 1213

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Examples

Sample Input
2
5 3
1 2
2 3
4 5

5 1
2 5
Sample Output
2
4




题意:

多个朋友聚餐, 彼此都不认识的朋友不能坐同一张桌子, 每次给出A和B认识, 求最少需要的桌子数量

题解:

非常基础的并查集题目了, 求一下不同par的数量即可, 用set或者改写unite操作都可以


#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <set>
using namespace std;
#define ms(x, n) memset(x,n,sizeof(x));
typedef  long long LL;
const LL maxn = 1010;

int T, N, M;
int par[maxn], rak[maxn];
void init(){
    ms(par, 0); ms(rak, 0);
    for(int i = 1; i <= N; i++)
        par[i] = i, rak[i] = 0;
}
int findr(int x){
    if(par[x]==x) return par[x];
    else return par[x] = findr(par[x]);
}
void unite(int x, int y){
    x = findr(x), y = findr(y);
    if(x == y) return;
    if(rak[x]<rak[y]){
        par[x] = y;
    }else{
        par[y] = x;
        if(rak[x]==rak[y]) rak[x]++;
    }
}
int main()
{
    cin >> T;
    while(T--){
        cin >> N >> M;
        init();
        int a, b;
        for(int i = 1; i <= M; i++){
            cin >> a >> b;
            unite(a, b);
        }
        set<int> s;
        for(int i = 1; i <= N; i++)
            s.insert(findr(i));
        cout << s.size() << endl;
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/a1097304791/article/details/87990933