【hdu1213】 How Many Tables 【并查集】

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

题目的大意是这样首先输入测试用例T,再输入人的个数以及他们的关系数,之后举出的几组说明他们是好朋友,可以坐在一张桌子上,问要多少张桌子。

利用并查集找到每一个朋友圈的代表元,再用set去重。

#include<bits/stdc++.h>
using namespace std;
int  pre[1050];
void init()
{
    for(int i=0;i<1050;i++)
    {
        pre[i]=i;
    }
}//初始化
int Find(int x)
{
    int r=x;
    while(r!=pre[r])
        r=pre[r];

    int i=x,j;
    while(pre[i]!=r)
    {
        j=pre[i];
        pre[i]=r;
        i=j;
    }
    return r;
}

void mix(int x,int y)
{
    int fx=Find(x),fy=Find(y);
    if(fx!=fy)
    {
        pre[fy]=fx;
    }
}
int a[1050];
int b[1050];
int main()
{
    set<int>s;
   int t;
  while(scanf("%d",&t)!=EOF)
  {


   int m,n;
   int i;
   while(t--)
   {
       init();
       s.clear();
       scanf("%d%d",&m,&n);
       for(i=0;i<n;i++)
       {
           scanf("%d%d",&a[i],&b[i]);

           mix(a[i],b[i]);
       }
//起初我只写了一次却wrong了,又发现了一组测试数据
//4 3
//1 2
//3 4
//3 2

//上面的操作不能将1的父亲指向3

//于是我又来了一遍。。
        for(i=0;i<n;i++)
       {


           mix(a[i],b[i]);
       }
       for(i=1;i<=m;i++)
       {

           s.insert(pre[i]);
       }

       printf("%d\n",s.size());
   }
  }

    return 0;
}

并查集有非常有趣的说明

https://blog.csdn.net/u013546077/article/details/64509038

猜你喜欢

转载自blog.csdn.net/swustzhaoxingda/article/details/81191767
今日推荐