HDU——1213 How Many Tables(并查集)

Problem Description

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

解题思路:

并查集练习

代码:

#include <cstdio>
#include <cstring>
using namespace std;

int pre[1010];
int branch[1010];

int find(int a){
    int temp = a;
    while(temp != pre[temp]){   //找到根结底
        temp = pre[temp];
    }

    int i = a , j;
    while(i != pre[i]){   //将该点的祖先节点的 pre 都改成当前找到的最高的那个 temp节点(当前所能找到的根节点)
        j = pre[i];
        pre[i] = temp;
        i = j;
    }

    return temp;
}

void join(int a , int b){
    int x = find(a);
    int y = find(b);

    if(x != y){
        pre[y] = x;
    }
}
int main(){
    int t , m ,n , a, b;
    int i ;
    int ans = 0;
    scanf("%d",&t);
    while(t --){
        scanf("%d %d",&m , &n);

        for(i = 1 ; i <= m ; i ++){
            pre[i] = i;
        }

        for(i = 1 ; i <= n ; i ++){
            scanf("%d %d",&a , &b);
            join(a , b);
        }

        memset(branch , 0 ,sizeof(branch));
        ans = 0;
        for(i = 1 ; i <= m ; i ++){
            branch[find(i)] = 1;
        }

        for(i = 1 ; i <=m ; i ++){  //查找有多少个根节点
            if(branch[i] == 1)
                ans ++;
        }

        printf("%d\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sinat_38052999/article/details/80053083