HDU 1213 How Many Tables [并查集]


Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

一道裸着的并查集题目,拿着练手很不错。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int ans, n, m;
int sett[1010];
int fin(int x)
{
    if(x!=sett[x]) sett[x]=fin(sett[x]);
    return sett[x];
}
void lianhe(int a,int b)
{
    int x=fin(a);
    int y=fin(b);
    if(x==y) return;
    ans-=1;
    sett[y]=x;

}
int main()
{
    while(cin>>n>>m&&n)
    {
        ans=n;
        for(int i=1;i<=n;i++) sett[i]=i;
        for(int i=1;i<=m;i++)
        {
            int a,b;
            cin>>a>>b;
            lianhe(a,b);
        }
        cout<<ans-1<<endl;
    }
}




猜你喜欢

转载自blog.csdn.net/j1nab1n9/article/details/78235930