HDU-1213-How Many Tables(并查集)

   
                                                     How Many Tables
 


Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output

2
4

题意描述:

给你n个点,m条边,有共同祖先的一些点称为一个团体,求有多少个团体

程序代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
int f[1010],n,m;
int getf(int u);
void merge(int u,int v);
int main()
{
	int T,i,j,k,sum,count=0,u,v;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&m);
		for(i=1;i<=n;i++)
			f[i]=i;
		sum=0;
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&u,&v);
			merge(u,v);
		}
		for(i=1;i<=n;i++)
			if(i==f[i])
				sum++;
		printf("%d\n",sum);
	}
	return 0;
}
int getf(int u)
{
	if(u==f[u])
		return u;
	f[u]=getf(f[u]);
	return f[u];
}
void merge(int u,int v)
{
	u=getf(u);
	v=getf(v);
	if(u==v)
		return;
	f[v]=u;
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/81454751