HDU - 1213 How Many Tables (并查集)

                                      How Many Tables

Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2

5 3

1 2

2 3

4 5

5 1

2 5

Sample Output

2

4

题意描述:

有n个朋友m个关系,相互认识的朋友可以坐在一桌,不认识的不能坐在一桌问n个朋友需要几张桌子。

解题思路:
将相互认识的存储为一个祖先,如果一个人的祖先为自己本身,则桌子数加一。

#include<stdio.h>
int f[1010];
int getf(int i)
{
	if(f[i]==i)
		return i;
	else
	{
		f[i]=getf(f[i]);
		return f[i];
	}
}
int merge(int u,int v)
{
	int t1,t2;
	t1=getf(u);
	t2=getf(v);
	if(t1!=t2)
	{
		f[t2]=t1;
		return 1;
	}
	return 0;
}
int main()
{
	int n,m,a,b,i,cut,t;
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d%d",&n,&m);
			for(i=1;i<=n;i++)	
				f[i]=i;
			for(i=1;i<=m;i++)
			{
				scanf("%d%d",&a,&b);
				merge(a,b);
			}
			cut=0;
			for(i=1;i<=n;i++)
				if(f[i]==i)
					cut++;
			printf("%d\n",cut);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/kongsanjin/article/details/81482312