HDU1312 - Red and Black (深度优先搜索)

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题意:

       房顶有红色黑色瓦片,@为起始位置站在黑瓦片上,‘.’代表黑瓦片‘#’代表红瓦片,只能上下左右四个方向移动只能走黑色瓦片,计算能到达的黑色瓦片的个数。

思路:

       还是把走过的点标记为‘#’,利用深度优先搜索计算,和计算油田的个数类似。

    一次就过了,开心啦啦啦。

代码:

#include<stdio.h>
char s[25][25];
int m,n,sum;
void dfs(int x,int y)
{
	int nx,ny,k;
	int next[4][2]={0,1, 1,0, 0,-1, -1,0};
	for(k=0;k<4;k++)
	{
		nx=x+next[k][0];
		ny=y+next[k][1];
		if(nx<0||nx>=n||ny<0||ny>=m)
			continue;
		if(s[nx][ny]=='.')
		{
			s[nx][ny]='#';
			sum++;
			dfs(nx,ny);
		}
	}
}
int main()
{
	int i,j;
	while(~scanf("%d%d",&m,&n))
	{
		if(m==0&n==0)
			break;
		sum=0;
		for(i=0;i<n;i++)
			scanf("%s",s[i]);
		for(i=0;i<n;i++)
			for(j=0;j<m;j++)
			{
				if(s[i][j]=='@')
				{
					s[i][j]='#';
					dfs(i,j);
					sum++;
				}
			}
			printf("%d\n",sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/wan_ide/article/details/81070309