PAT (Advanced Level) Practice 1009 Product of Polynomials (25 分) (C++)(甲级)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/m0_37454852/article/details/85639998

1009 Product of Polynomials (25 分)

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:

K N​1​​ aN​1N​2 a​N2… N​K aNK

where K is the number of nonzero terms in the polynomial, N​i and a​N​i (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K <⋯<N2 <N1≤1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output:

3 3 3.6 2 6.0 1 1.6


#include <cstdio>
#include <cstring>
#include <cmath>

double A[1001] = { 0 }, B[1001] = { 0 };//下标存放指数,内容为系数
double result[2001] = { 0 };//存放乘积的指数系数,指数最大为1000+1000

int main()
{
	int n = 0;
	int exp = 0;
	double coe = 0;
	int cnt = 0;
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d %lf", &exp, &coe);
		A[exp] = coe;
	}
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
	{
		scanf("%d %lf", &exp, &coe);
		B[exp] = coe;
	}
	for (int i = 0; i <= 1000; i++)
	{
		for (int j = 0; j <= 1000; j++)
		{
			if (A[i] && B[j])
			{
				result[i + j] += A[i] * B[j];//乘法规则,指数相加,系数相乘;注意为累加
			}
		}
	}
	for (int i = 0; i < 2001; i++) if (result[i]) cnt++;//计算项数
	printf("%d", cnt);
	if(!cnt) printf(" 0 0.0");//最终结果为0;不过貌似测试用例没测试这个的
	for (int i = 2000; i >= 0; i--)
	{
		if (result[i])
			printf(" %d %.1lf", i, result[i]);//输出即可了
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_37454852/article/details/85639998