poj2352 Stars

Stars
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 51934   Accepted: 22360

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.


题目大意:

给你n个点代表n个星星,以该点为起点向x,y轴作垂线,会得到一个矩形,这个矩形里面所包含的星星数(不包括它本身)称为该星星的等级 ,要求输出在0-n-1等级各有多少个星星。注意给出的点的顺序很有讲究,是按照y坐标升序给出,如果y坐标相同,则按照x坐标升序给出。

思路:树状数组,因为是按着y的升序排列,y相同时按着x的升序排列,所以当前坐标为y的星星一定覆盖它前面的(坐标小于y)所以星星,因此可以把所以的星星坐标都投影到x轴上,用树状数组保存。

要注意考虑x为0时的特殊情况,这里处理是把x都加了1,原等级也会降1。。


ac代码

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

int d[32005],n;//原数组长度
int le[15005];
int lowbit(int x)
{
    return x&(-x);
}
int query(int x)//查询前缀和
{
    int res = 0;
    while(x)
    {
        res += d[x];
        x -= lowbit(x);
    }
    return res;
}
void add(int x,int v)//对a[x]进行修改,后面的每一个后缀和都会变化
{
    while(x <= n)
    {
        d[x] += v;
        x += lowbit(x);
    }
}

int main()
{
    n = 32005;
    int t;
    scanf("%d",&t);
    for(int i = 0; i < t; i++)
    {
        int x,y;
        scanf("%d %d",&x,&y);

        le[query(x+1)]++;//初始的等级1变成了0
        add(x+1,1);
    }
    for(int i = 0; i < t; i++)//等级从0开始
        cout<<le[i]<<endl;
    return 0;
}

猜你喜欢

转载自blog.csdn.net/ac_blood/article/details/79886709