POJ 2352 Stars 线段树

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

扫描二维码关注公众号,回复: 2851691 查看本文章

题意:

求每一个星星的级别, 最后输出各个级别的个数。

思路:

因为题目是给出了按Y坐标升序排列的, 所以我们只要关心X坐标的大小关系就可以了。

利用线段树去维护各个区间的节点个数, 边查询边更新。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=32005;
int tree[maxn<<2];
int level[maxn];
int n;
//坐标
struct loc
{
    int x,y;
};
loc l[maxn];
void pushup (int re)
{
    tree[re]=tree[re<<1]+tree[re<<1|1];
}
void build (int l,int r,int re)
{
    tree[re]=0;
    if(l==r)
        return;
    int mid=(l+r)>>1;
    build (l,mid,re<<1);
    build (mid+1,r,re<<1|1);
}
int query (int l,int r,int re,int left,int right)
{
      if(l>=left&&r<=right)
        return tree[re];
      int mid=(l+r)>>1;
      int ans=0;
      if(left<=mid)
        ans+=query (l,mid,re<<1,left,right);
      if(right>mid)
        ans+=query (mid+1,r,re<<1|1,left,right);
      return ans;
}
void update (int l,int r,int re,int loc)
{
    if(l==r)
    {
        tree[re]++;
        return;
    }
    int mid=(l+r)>>1;
    if(mid>=loc)
        update (l,mid,re<<1,loc);
    else
        update (mid+1,r,re<<1|1,loc);
    pushup (re);
}
int main()
{
    scanf("%d",&n);
    memset (level,0,sizeof(level));
    build (1,maxn,1);
    for (int i=1;i<=n;i++)
    {
        scanf("%d%d",&l[i].x,&l[i].y);
        l[i].x++;
        //区间查询
        int temp=query(1,maxn,1,1,l[i].x);
        //单点更新
        update (1,maxn,1,l[i].x);
        level[temp]++;
    }
    for (int i=0;i<n;i++)
        printf("%d\n",level[i]);

    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41410799/article/details/81713137