POJ2352 HDU1541 Stars【树状数组】

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 52863   Accepted: 22766

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.  

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.  

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.  

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source


问题链接POJ2352 HDU1541 Stars

问题描述:(略)

问题分析:这个问题用树状数组来解决,先占个位置不解释。

程序说明:(略)

参考链接:(略)

题记(略)


AC的C++语言程序如下:

/* POJ2352 HDU1541 Stars */

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;

const int N = 32001;
int n, a[N + 1], ans[N + 1];

int lowbit(int i)
{
    return i & -i;
}

void update(int i, int v) //更新函数
{
    while(i <= N) {     // 这个N,与一般函数有所不同
        a[i] += v;
        i += lowbit(i);
    }
}

int sum(int i)      //求和函数
{
    int sum = 0;
    while(i > 0) {
        sum += a[i];
        i -= lowbit(i);
    }
    return sum;
}

int main()
{
    while(~scanf("%d", &n)) {
        memset(a, 0, sizeof(a));
        memset(ans, 0, sizeof(ans));

        for(int i = 1; i <= n; i++) {
            int x, y;
            scanf("%d%d", &x, &y);
            x++;
            ans[sum(x)]++;
            update(x, 1);
        }

        for(int i = 0; i < n; i++)
            printf("%d\n", ans[i]);
    }

    return 0;
}





猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/80935129