POJ 2352 Stars(树状数组)

Stars

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 53403   Accepted: 22978

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

Source

Ural Collegiate Programming Contest 1999

因为星星的坐标是按照y升序排列,然后y相同的再按照x升序排列。题意是将星星分了级,星星的级别就是它左下方星星的数量。判断一个星星的级数,找出在他前面有几个星星的x坐标比它小即可。树状数组套一下模板即可,要注意因为x坐标可能为0,为了防止在更新操作中出现死循环(如果不是很明白的话代码中有解释),需要把所有的x坐标值+1。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=32005;
int n,x,y,c[maxn],a[maxn];
int lowbit(int x)
{
    return x&-x;
}
void update(int p,int v)
{
    while(p<=maxn)//死循环会出现在此,因为lowbit(0)=0,所以一直跳不出循环
    {
        c[p]+=v;
        p+=lowbit(p);
    }
}
int sum(int p)
{
    int ans=0;
    while(p>0)
    {
        ans+=c[p];
        p-=lowbit(p);
    }
    return ans;
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        scanf("%d %d",&x,&y);
        update(x+1,1);
        a[sum(x+1)]++;
    }
    for(int i=1;i<=n;i++)
        printf("%d\n",a[i]);
}

猜你喜欢

转载自blog.csdn.net/baymax520/article/details/81273961