poj2352 Stars【树状数组】

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

思路:每个星星有一个等级,就是它左下角星星的个数,让你统计一下。符合树状数组的思想

#include<cstdio>
#include<cstring>
#include <iostream>
using namespace std;
const int maxn=32005;
int l[maxn],c[maxn];
int lowbit(int i)
{
    return i & -i;//或者是return i-(i&(i-1));表示求数组下标二进制的非0最低位所表示的值
}
void update(int i,int val)//单点更新
{
    while(i<=maxn)
    {
        c[i]+=val;
        i+=lowbit(i);//由叶子节点向上更新树状数组C,从左往右更新
    }
}
int sum(int i)//求区间[1,i]内所有元素的和
{
    int ret=0;
    while(i>0)
    {
        ret+=c[i];//从右往左累加求和
        i-=lowbit(i);
    }
    return ret;
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(l,0,sizeof(l));
        memset(c,0,sizeof(c));
        int x,y;
        for(int i=0;i<n;++i)
        {
            scanf("%d%d",&x,&y);
            l[sum(++x)]++;
            update(x,1);
        }
        for(int i=0;i<n;++i)
            printf("%d\n",l[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_41785863/article/details/83757561