POJ - 2352 Stars (树状数组)

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0 

感觉这是个非常抽象的树状数组,题目中的星星的输入已经排好序列(等y从小到大x从小到大,x相)可以抽象的理解将所有x坐标看成树状数组,输入一个坐标更新一次(输入的顺序保证了前边输入的星星包含在后边输入的星星左下角!!!!)

x是多少就在相应位置更新add(x,1),对于级别的统计,开一个数组ans[],对于每一个坐标read(x),ans[read()]

借用图片便于理解

ac代码

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>

using namespace std;
int d[32005],ans[32005];
int lowbit(int k)
{
	return (k&(-k));
}
void add(int pos,int v)
{
	while (pos <= 100 + 1)
	{
		d[pos]+=v;
		pos += lowbit(pos);
	}
}
int read(int k)
{
	int sum=0;
	while(k>0){
		sum+=d[k];
		k-=lowbit(k);
	}
	return sum;
}
int main(){
	int x,y,n;
	while(cin>>n)
	{
		memset(ans,0,sizeof(ans));
		memset(d,0,sizeof(d));
		for(int i=0;i<n;i++)
		{
			cin>>x>>y;
			x++;
			ans[read(x)]++;//查询此刻坐标等级,ans++
			add(x,1);//添加
		}
		for(int i=0;i<n;i++)
		{
			cout<<ans[i]<<endl;
		}
		
	}
	return 0;
	
}

猜你喜欢

转载自blog.csdn.net/henu_xujiu/article/details/81185271