POJ2352Stars解题报告---树状数组

版权声明:转载请注明出处:https://blog.csdn.net/qq1013459920 https://blog.csdn.net/qq1013459920/article/details/87607817

                                                        Stars

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

扫描二维码关注公众号,回复: 5482013 查看本文章

题意:

在坐标上有n个星星,如果某个星星坐标为(x, y), 左下位置规定为:(x0,y0),x0<=x 且y0<=y。如果左下位置有x个星星,则这个星星属于level x

按照y递增,如果y相同则x递增的顺序给出n个星星,依次输出 level 1到 level max 的星星数量。

分析:

因为按照y递增,y相同则x递增的顺序输入,所以对于第i颗星星,它的level就是之前输入的星星中,横坐标<= xi的星星数量(前面的y <= 后面的已经确定)

 AC Code:

#include <iostream>
#include <queue>
#include <stack>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <vector>
#include <algorithm>
#include <map>
#include <set>
#define Mod 1000000007
#define INF 0x3f3f3f3f
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
#define eps 1e-8
#define lowbit(x) (x&-x);
typedef long long ll;
using namespace std;
static const int MAX_N = 32005;
const double pi = acos(-1);
int a[MAX_N], c[MAX_N];
int res[MAX_N];
int sum(int x) {
	int ret = 0;
	while(x){
		ret += c[x];
		x -= lowbit(x);
	}
	return ret;
}
void add(int x, int d) {
	while (x <= MAX_N) {
		c[x] += d;
		x += lowbit(x);
	}
}
int main(){
	int n;
	while (scanf("%d", &n) != EOF) {
		memset(c, 0, sizeof(c));
		memset(res, 0, sizeof(res));
		for (int i = 0; i < n; i++) {
			int x, y;
			scanf("%d%d", &x, &y);
			x++;
			res[sum(x)]++;
			add(x, 1);
		}
		for (int i = 0; i < n; i++) {
			printf("%d\n", res[i]);
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq1013459920/article/details/87607817