POJ-2352:Stars

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/wingrez/article/details/82962706

POJ-2352:Stars

来源:POJ

标签:树状数组

参考资料:

相似题目:

题目

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.
在这里插入图片描述
For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.
You are to write a program that will count the amounts of the stars of each level on a given map.

输入

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

输出

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

输入样例

5
1 1
5 1
7 1
3 3
5 5

输出样例

1
2
1
1
0

提示

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

解题思路

注意题目按序输入(y升序,若y相等再x升序)。假设当前点是(x1,y1)(那么其实已经确定它的等级了,原因还是按序输入),我们只需要求当前x小于等于x1的点的个数(不包括点(x1,y1))。采用树状数组(注意x>=0,而树状数组索引从1开始)或线段树都可以解决此题。

参考代码

#include<stdio.h>
#include<string.h>
#define MAXN 40000
int c[MAXN+10];//树状数组
int level[MAXN/2];//记录每个等级的个数

inline int lowbit(int x){ return x&-x; }

void update(int x){
    while(x<=MAXN){
        c[x]++;
        x+=lowbit(x);
    }
}

int sum(int x){
    int ret=0;
    while(x>0){
        ret+=c[x];
        x-=lowbit(x);
    }
    return ret;
}

int main(){
    int n;
    while(~scanf("%d",&n)){
        memset(c,0,sizeof(c));
        memset(level,0,sizeof(level));
        for(int i=0;i<n;i++){
            int x,y;
            scanf("%d%d",&x,&y);
            update(x+1);//将x坐标加1,满足树状数组索引要求,下同。
            level[sum(x+1)-1]++;//减1是因为不包括当前的点。
        }
        for(int i=0;i<n;i++)
            printf("%d\n",level[i]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wingrez/article/details/82962706