POJ - 2352 Stars

POJ - 2352  Stars

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 


For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

树状数组好难啊,,两天才弄懂一道题。

题目大意:按y的升序(y相同则按x升序)给出n(1<=n<=15000)个星星的坐标(0<=x,y<=32000),每个星星左下方(包括同一行或同一列)的星星个数为它的“等级”,依次输出等级为1,2,3,...,n-1的星星的个数。

思路来自:https://blog.csdn.net/c20190102/article/details/60139150

这篇讲的可以说是很清晰了。。嘻嘻

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 420000
int c[maxn],n;
int levels[maxn];
int lowbit(int x){
	return x&(-x);
}
//这里是对前x进行求和; 
int getsum(int x){
	int sum=0;
	for(int i=x;i>0;i-=lowbit(i))
	{
		sum+=c[i];
	}
	return sum;
}//这里的目的是给下标为i的加上1,这样的话下次询问前面的就能够累加上去了;
void update(int x,int val){
	for(int i=x;i<=maxn;i+=lowbit(i))
	{
		c[i]+=val;
	}
} 
int main(){
	int n,x,y;
	while(scanf("%d",&n)!=EOF){
		memset(levels,0,sizeof(levels));
		memset(c,0,sizeof(c));
		int tt=n;
		while(tt--){
			scanf("%d%d",&x,&y);
			x++;
			levels[getsum(x)]++;//levrl 表示 getsum(x)等级的个数  getsum 表示 比x小的星星个数
			//cout<<getsum(x)<<endl; 
			update(x,1);//更新后面的值. 
			//for(int i=1;i<=10;i++)
			//{
			//	cout<<c[i]<<" ";
			// }cout<<endl;
		}
		for(int i=0;i<n;i++) printf("%d\n",levels[i]);//阶级从0开始哦
	}return 0;
}

 

猜你喜欢

转载自blog.csdn.net/qq_40046426/article/details/81164392