Stars POJ - 2352 (树状数组)

Stars POJ - 2352 (树状数组)

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it’s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5
Sample Output
1
2
1
1
0
Hint
This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题目大意:

在坐标上有n个星星,如果某个星星坐标为(x, y), 它的左下位置为:(x0,y0),x0<=x 且y0<=y。如果左下位置有a个星星,就表示这个星星属于level x
按照y递增,如果y相同则x递增的顺序给出n个星星,求出所有level水平的数量。

解题思路:

树状数组的应用
树状数组的详细介绍博客:
https://blog.csdn.net/weixin_43179892/article/details/89490577

AC代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=32005;
int c[maxn];
int ans[maxn];
int lowbit(int x)
{
	return x&(-x);
}
void update(int x,int y)
{
	for(int i=x;i<=maxn;i+=lowbit(i))
		c[i]+=y;
}
int getsum(int x)
{
	int res=0;
	for(int i=x;i>0;i-=lowbit(i))
		res+=c[i];
	return res;
}
 
int main()
{
	int n;
	cin>>n;
	memset(c,0,sizeof(c));
	memset(ans,0,sizeof(ans));
	for(int i=0;i<n;i++)
	{
		int x,y;
		cin>>x>>y;
		ans[getsum(x+1)]++;
		update(x+1,1);
	}
	for(int i=0;i<n;i++)
		cout<<ans[i]<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_43179892/article/details/89493357