Max Sum Plus Plus hdu1024

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34644    Accepted Submission(s): 12376


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
 
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
 
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
 

Author
JGShining(极光炫影)
 

Recommend
We have carefully selected several similar problems for you:   1074  1025  1081  1080  1160 

题目大意:给你n个数,划分成m块,求m块连续串的和最大值

状态转移方程: dp[i][j]=max(dp[i][j-1]+a[j],max(dp[i-1][k])+a[j]);

i表示划分成i个区块,j表示前j个数,a[j]为答案的最后一个元素,必定包含。

两种情况 

  a[j]属于第i块,接在j-1后面;

  a[j]不属于i块,独立成一块,再加上前k个元素分成i-1块的最大值,其中 0<k<j

两种情况求最大值,两点原因必须优化:1.N=1000000 ,数组开不到那么大;2.两个max,套三层循环,超时

观察状态转移方程,可以改写成滚动数组形式:dp[i][j]的决策只取决于前面j-1个元素

  对于max(dp[i-1][k])这层循环可以用数组记录每次的最大值

#include <iostream>

#include <cstring>
#include <algorithm>
using namespace std;
#define N 1000000  
#define INF 0x7fffffff  
int dp[N+10],Max[N+10];
int a[N+10];
int main()
{
int n,m,mmax;
while(scanf("%d %d",&m,&n)!=EOF)
     {
       for(int i=1;i<=n;i++)
           scanf("%d",&a[i]);
        memset(dp,0,sizeof(dp));
        memset(Max,0,sizeof(Max));
for(int i=1;i<=m;i++) //分m块
   {
    mmax=-INF;
  for(int j=i;j<=n;j++)//至少一个元素一块吧
      {
       dp[j]=max(Max[j-1],dp[j-1])+a[j];
        Max[j-1]=mmax;
        mmax=max(dp[j],mmax);
  }
 

printf("%d\n",mmax);  
 }
  return 0;

猜你喜欢

转载自blog.csdn.net/qq_41603898/article/details/80209536