HDU1024 Max Sum Plus Plus (优化线性dp)

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^

InputEach test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
OutputOutput the maximal summation described above in one line.
Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8


        
 

Hint

Huge input, scanf and dynamic programming is recommended.
#include <bits/stdc++.h>
#define INF 1<<30
using namespace std;
int a[1000005];
int dp[1000005]={0};
int lmax[1000005]={0};
int main()
{
    int m,n;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        int i,j;
        memset(dp,0,sizeof(dp));
        memset(lmax,0,sizeof(lmax));
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        int ans=0;
        for(i=1;i<=m;i++)
        {
            ans=-INF;
            for(j=i;j<=n;j++)
            {
                dp[j]=max(dp[j-1]+a[j],lmax[j-1]+a[j]);
                lmax[j-1]=ans;
                ans=max(ans,dp[j]);
            }
        }
        cout<<ans<<endl;
    }    
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/lipoicyclic/p/12324242.html