hdu1024—Max Sum Plus Plus(最大M子段和)

题目链接:传送门

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34604    Accepted Submission(s): 12363


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 ... S n.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
 
  
1 3 1 2 32 6 -1 4 -2 3 -2 3
 
Sample Output
 
  
68
Hint
Huge input, scanf and dynamic programming is recommended.
 

解题思路:

我们用dp[i][j]表示前j个数划分为k段的最大和,且以第j个数结尾。

于是有状态转移方程dp[i][j] = max(dp[i][j-1],dp[i-1][k])+data[j]  (i-1 <= k <= j-1)。

这里我们可以用滚动数组对上述方程的空间进行优化。

用r[j]表示dp[i-1][k]的最大值,dp[j]表示dp[i][j],于是有dp[j] = max(dp[j-1],r[j-1])+data[j]。而r的值可由上一层的dp值得到。


代码:

#include <iostream>
#include <stack>
#include <vector>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>

using namespace std;

typedef long long llt;

const int N = 1000010;
const int M = 510;
const llt INF = 0x3ffffffffffffff;
const int mod = 10000;

llt r[N],dp[N],data[N];

int main()
{
    int m,n; llt c;
    while(~scanf("%d%d",&m,&n)){
        for(int i = 1; i <= n; ++i) scanf("%lld",&data[i]);
        memset(r,0,sizeof(r));
        for(int i = 1; i <= m; ++i){
            c = -INF;
            for(int j = i; j <= n; ++j){
                dp[j] = max(dp[j-1],r[j-1])+data[j];
                r[j-1] = c;
                c = max(c,dp[j]);
            }
        }
        printf("%lld\n",c);
    }
    return 0;
}


猜你喜欢

转载自blog.csdn.net/jiangzhiyuan123/article/details/80188002