HDU1024 Max Sum Plus Plus【最大子段和+DP】

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 48242 Accepted Submission(s): 17584

Problem Description
Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. _

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.
Process to the end of file.

Output
Output the maximal summation described above in one line.

Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output
6
8

Hint
Huge input, scanf and dynamic programming is recommended.

问题链接HDU1024 Max Sum Plus Plus
问题简述:给定一个长度为n的整数序列,从中找出m段不相交的子序列,使得这m段子序列和之和为最大。
问题分析:状态转换方程为f[j]=max(f[j-1],pre[j-1])+a[j]。其中,f[j]定义为选取第j个元素情况下前j个元素的最大和,pre[j]定义为到j为止的最大和。这个题的关键是推导出状态转换方程。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* HDU1024 Max Sum Plus Plus */

#include <bits/stdc++.h>

using namespace std;

const int INF = 0x7F7F7F7F;
const int N = 1e6;
int a[N + 1], dp[N + 1], pre[N + 1];

int main()
{
    int m, n;
    while(~scanf("%d%d", &m, &n)) {
        int maxSum;

        for(int i = 1; i <= n; i++) scanf("%d", &a[i]);

        memset(dp, 0, sizeof(dp));
        memset(pre, 0, sizeof(pre));
        for(int i = 1; i <= m; i++) {
            maxSum = -INF;
            for(int j = i; j <= n; j++) {
                dp[j] = max(dp[j - 1], pre[j - 1]) + a[j];
                pre[j - 1] = maxSum;
                maxSum = max(maxSum, dp[j]);
            }
        }

        printf("%d\n", maxSum);
    }

    return 0;
}
发布了2289 篇原创文章 · 获赞 2373 · 访问量 265万+

猜你喜欢

转载自blog.csdn.net/tigerisland45/article/details/105425286