PTA甲级 1069 The Black Hole of Numbers (20分)--水题

题目原文

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 – the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we’ll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,104).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

题目大意

就是给你一个数(0-9999)然后让你用这个数字 个位,十位,百位,千位上的4个数字,组成一个最大的数,和一个最小的数.

然后它们相减. 相减后的数字如果是6174或者0就停止.

不然就一直这样继续.

我的思路:

就是用一个数组保存这4个数字,然后算出最大和最小.

然后一直循环.

我的代码:

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int main() {
    int min = 0, max = 0,New;
    vector<int> inex;
    cin >> New;
    do{
    int t = 0;
    while (New) {
        t = New % 10;
        inex.push_back(t);
        New /= 10;
    }
    while (inex.size() != 4) {
        inex.push_back(0);
    }
    sort(inex.begin(), inex.end());
    min=0;
    min=inex[0]*1000+inex[1]*100+inex[2]*10+inex[3];
    max=inex[3]*1000+inex[2]*100+inex[1]*10+inex[0];
    New = max-min;
    printf("%04d - %04d = %04d\n",max,min,New);;
    inex.clear();
    }while(New!=0&&New%1111!=0&&New!=6174);
    return 0;
}

柳神的代码

#include <iostream>
#include <algorithm>
using namespace std;
bool cmp(char a, char b) {return a > b;}
int main() {
    string s;
    cin >> s;
    s.insert(0, 4 - s.length(), '0');
    do {
        string a = s, b = s;
        sort(a.begin(), a.end(), cmp);
        sort(b.begin(), b.end());
        int result = stoi(a) - stoi(b);
        s = to_string(result);
        s.insert(0, 4 - s.length(), '0');
        cout << a << " - " << b << " = " << s << endl;
    } while (s != "6174" && s != "0000");
    return 0;
}

柳神的代码和我的差不多,不过比起我的代码,她的代码高度集成化.

猜你喜欢

转载自blog.csdn.net/Huangpengyu123/article/details/107091439
今日推荐