NYOJ 贪心算法 218 Dinner

Dinner

时间限制:100 ms  |  内存限制:65535 KB

难度:1

描述

Little A is one member of ACM team. He had just won the gold in World Final. To celebrate, he decided to invite all to have one meal. As bowl, knife and other tableware is not enough in the kitchen, Little A goes to take backup tableware in warehouse. There are many boxes in warehouse, one box contains only one thing, and each box is marked by the name of things inside it. For example, if "basketball" is written on the box, which means the box contains only basketball. With these marks, Little A wants to find out the tableware easily. So, the problem for you is to help him, find out all the tableware from all boxes in the warehouse.

输入

There are many test cases. Each case contains one line, and one integer N at the first, N indicates that there are N boxes in the warehouse. Then N strings follow, each string is one name written on the box.

输出

For each test of the input, output all the name of tableware.

样例输入

3 basketball fork chopsticks
2 bowl letter

样例输出

fork chopsticks
bowl

提示

扫描二维码关注公众号,回复: 4150374 查看本文章

The tableware only contains: bowl, knife, fork and chopsticks.

一道非常简单的题,虽然是水题但是还是要写博客的啦。不多说,直接上代码啦。

 
#include <iostream>
#include<stdio.h>
#include <string.h>
using namespace std;
int main(int argc,char* argv[])
{
    int n,i,l,j;
    char stick[100][20],u[4][20]={"bowl","knife","fork","chopsticks"},slect[100][20];
    while(~scanf("%d",&n))
    { l=0;
      for(i=0;i<n;i++)
        scanf("%s",stick[i]);
      for(i=0;i<n;i++)
       for(j=0;j<4;j++)
       if(strcmp(stick[i],u[j])==0)
       {
           strcpy(slect[l++],stick[i]);
           break;
       }
       for(i=0;i<l;i++)
       {
           if(i!=l-1)
           printf("%s ",slect[i]);
           else
           printf("%s\n",slect[i]);
       }
    }
    return 0;
}
        

猜你喜欢

转载自blog.csdn.net/qq_41661918/article/details/81605806
今日推荐