逆元模板题 HDU - 1576

逆元模板题

要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。

Input

数据的第一行是一个T,表示有T组数据。 
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。

Output

对应每组数据输出(A/B)%9973。

Sample Input

2
1000 53
87 123456789

Sample Output

7922
6060
#include<cstdio>
#include<cstring>
using namespace std;


void ex_gcd(int a,int b,int &x,int &y) {
	if(b==0) {
		x=1;
		y=0;
	} else {
		ex_gcd(b,a%b,x,y);
		int temp =x;
		x = y;
		y = temp-(a/b)*y;
	}
}

int main() {
	int x,y;
	long long B,n;
	int t;
	scanf("%d",&t);
	while(t--) {
		scanf("%lld%lld",&n,&B);
		ex_gcd(B,9973,x,y);
		x=x*n;
		x= (x%9973 +9973)%9973;
		printf("%lld\n",x);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42506224/article/details/84064763